DosBox got dead, please help!

General discussion. Please use this area for any off-topic discussion.
Catalyst_Kh
Posts: 117
Joined: Sat Aug 25, 2012 7:49 pm

DosBox got dead, please help!

Postby Catalyst_Kh » Mon Feb 11, 2013 7:58 pm

Several days ago everything worked normal. But now my dosbox doesn't run with the following error:

"The application failed to initialize properly (0xc000007b)"

I googled about and found out that it is a common problem for many applications under Windows 7 x64, but at x32 there is nothing like that. It seems extremely grim to reinstall all operation system to fix that, but nothing else helped so far. :(

Reinstall of dosbox doesn't helped of course. The suggestion from microsoft forum was to ensure that all hardware drivers are good, official and up to date - that i did. Also there was several topics about that java update brought this error, and i exactly had java autoupdate last day or two, which fits the scenario. I removed java, reinstalled visual c++ redistributables 2010, both x32 and x64, as was suggested somewhere too. Still it doesn't help. With no java (and reboot) it doesn't works, with installed oracle java doesn't works too, maybe there is some other java you could recommend? Or some way to clean up something in the registry about java or else?

Please suggest what else can i try, or how did you cured that problem when you had it. Thank you for any tip.

Catalyst_Kh
Posts: 117
Joined: Sat Aug 25, 2012 7:49 pm

Postby Catalyst_Kh » Mon Feb 11, 2013 9:03 pm

I performed some intense bruteforcing and got lucky. The problem this time was hilarious! Either that java update or recent windows update deleted opengl32.dll file from syswow64 system folder - it is just completely mindblowing! What for that was done, i have no slightest idea, it is just so silly...

And opengl32.dll file inside system32 folder is of different version, so just copying opengl32.dll from system32 to syswow64 didn't solved the problem. I found previous version of opengl32.dll and putted it in syswow64, and dosbox went alive and works normal now. But i kept newer version in system32 folder - who knows what will crash next if i will undo this strange update in system32 folder...

Anyway, if you will catch this illness here are both files to cure:
http://www.mediafire.com/?ygg6dog60vy0x8i

Good luck


Return to “General Discussion”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest